| Sign In | Join Free | My futurenowinc.com |
|
All wholesale umbrellas wholesalers & wholesale umbrellas manufacturers come from members. We doesn't provide wholesale umbrellas products or service, please contact them directly and verify their companies info carefully.
| Total 178 products from wholesale umbrellas Manufactures & Suppliers |
|
|
|
Model Number:FU-006 Brand Name:FULL Place of Origin:China ... - Ideal for Corporate Marketing & Outdoor Events Our wholesale custom 3 fold manual umbrella is a top-selling promotional giveaway item designed for corporate promotions, brand activations, trade shows, charity drives and large-scale outdoor ... |
Shenzhen Fxinda Umbrella Company Limited
Guangdong |
|
|
Brand Name:UP Model Number:UP-L18 Place of Origin:Fujian,China Wholesale SilkLogo Plastic Straight Handle Compact 2 Fold Umbrella Why Choose us 1. Hundreds of skilled workers , 8-10 of the QC team. 2. Sales at least have 3 years experience who can provide professional service, 3. All in inquiries can be replied within 12 hours. Product Quick Details: Item Wholesale SilkLogo Plastic Straight Handle Compact 2 Fold Umbrella... |
Xiamen United-Prosperity Industry & Trade Co., Ltd.
Fujian |
|
|
Brand Name:TOKO Model Number:S19-011 Place of Origin:China Wholesale Custom Led Light Dome Shaped Bubble Clear Transparen Child Kid Led Umbrella No.1 Product Information Model Number Wholesale Custom Led Light Dome Shaped Bubble Clear Transparen Child Kid Led Umbrella Size 23"*8K Fabric Pongee Shaft Material Acrylic Rib Material Fiberglass Handle Black MOQ 1 Piece,Welcome Sample Order Open Type Manual Type Wholesale Custom Led Light Dome Shaped Bubble Clear Transparen Child Kid Led Umbrella... |
Xiamen Toko Umbrella Co.,Ltd.
Fujian |
|
|
Place of Origin:Xiamen Brand Name:WINTOP Model Number:WTL136 ...umbrella wholesaler Sizes : Radius 23", Arc 46" Frame : Manual black Steel Frame with fiberglass ribs, reverse mechanism Canopy : 190t Pongee double layers, outside layer is black, inner layer is rose printed Handle : Rubberized plastic curved handle Certificate : En71, Azo, Upf Minimum Order Quantity : 1200PCS 1. Rose stylish fashion and vogue reverse umbrella wholesaler... |
XIAMEN WINTOP IMP. AND EXP. CO., LTD
Fujian |
|
|
Place of Origin:Fujian, China Brand Name:YLF Model Number:YLF-GD020 ...Wholesale Personality Sublimation Golf Umbrella Logo Prints Promotional Umbrella STRAIGHT GOLF UMBRELLA DETAILS Focus On Customization of Golf Umbrella Freely Custom Your Design Logo We Supply What's the main features of Jarmoo logo prints promotional umbrella... |
Jinjiang YLF Umbrella Co., Ltd.
Fujian |
|
|
Brand Name:GoodPartner Model Number:BS1714005 Place of Origin:China ... pvc wholesalers uv coca cola Function Sunshade and advertising Material of canopy 600D Oxford fabric in color Color of the canopy Custom ... |
Xiamen GoodPartner Umbrella Co., Ltd
Fujian |
|
|
Model Number:S Place of Origin:China Brand Name:SWJ ... Tube Stick, Empty Cosmetic Container for Lip Care Products Product Short Description Wholesale 4.5ml empty umbrella-type lip gloss tube stick made of premium plastic material, featuring unique umbrella-shaped design, lightweight and portable, ideal for |
Yuyao Bill Spray Co.,Ltd
Zhejiang |
|
|
Place of Origin:Foshan, China Brand Name:AC MIU Model Number:102 China garden outdoor umbrellas beach umbrella Place: home, Hotel, Yard, Garden, Balcony, Restaurant etc. Features: 1: Excellent pure hand weaving technique with popular style. 2: Reasonable price and superoir quality. 3.Water repellent cushions ensure ... |
AC MIU Furniture Co., Ltd
Guangdong |
|
|
Brand Name:SNUGLANE Model Number:FSPU-02 Place of Origin:China ... for years of enjoyment,Easy open/close system puts the umbrella up in just seconds with minimal effort.Detachable pole contributes to easy setup and storage. Size: Item No. FSPU-02 Size ... |
Guangzhou Snuglane Industries Inc.
Guangdong |
|
|
Brand Name:HS Model Number:HSUB001 Place of Origin:China Biodegradable Transparent Plastic Umbrella Wrapping Bags Disposable Umbrella Wet Bag Wholesale ITEM: Wet Umbrella Poly Bags Material: LDPE, HDPE Thickness from 12um to 30um Size: 7'' x 24''; 7'' x31'' ;7'' x 35'' or customized sizes Printing: We can print... |
Dongguan Hengsheng Polybag Co., Ltd.
Guangdong |
|
|
Categories:Patio umbrella base Country/Region:china Key attributes Industry-specific attributes application Outdoor, Hotel, Mall, Sports Venues, Park, Courtyard, Exterior, Gym design style Traditional type Base Other attributes mail packing N general use Outdoor Furniture Pole Material Stainless Steel place... |
Foshan Yoshen Outdoor Furnishing Co.,Ltd
Guangdong |
|
|
Place of Origin:China Brand Name:hifine Model Number:HFU-013 Product Description Steel parasol Size: Dia. 3.0m(Radii: 1.50m)H:2m Fabric: polyester 160G ribs:8ribs,12X18mm Pole:dia. 38 mm pole W/o tilt, W/oflap W/airvent Powdered Frame Product Name Steel parasol Style Garden Umbrella Size Dia. 3.0m Colour ... |
jiaxing hifine international enterprise co ltd
Zhejiang |
|
|
Place of Origin:Zhejiang, China Brand Name:Saixin Model Number:ZT-358 Product Description Product name: Factory wholesale wedding table centerpieces gold metal umbrella Material: Metal Decoration: wedding event,home,party Package: 1 piece / carton,safe packages,good foam with carton Size: H:100cm*W:70cm Color: Gold,silver,... |
PUJIANG SAIXIN DECOR LLC
Zhejiang |
|
|
Brand Name:I AM YOUR FANS Place of Origin:China
|
I AM YOUR FANS CRAFTS TRADING CO.,LTD.
Hunan |
|
|
Place of Origin:Guangdong, China (Mainland) Brand Name:Uwin Model Number:#L30018 Cute Girl's Characters with Umbrella Towel Embroidery Patch Wholesale Cheap and Various Colors' Embroidery Patch#L30018 Production Description Attribute Product name Girl Types of Patch Towel Embroidery Material twill,felt,velvet,cloth fabric,flannel,tower... |
Guangzhou Yangying Garment Co., Ltd.
Guangdong |
|
|
Brand Name:BAGPLASTICS@VIP.163.COM Model Number:WHATSAPP:+8613780964661 Place of Origin:CHINA Multifunctional Advertising Tent With Water Sand Filling, Weight-Proof Sand Bag,Wholesale Tent Fixed Water Bucket Advertisement Sunshade Umbrella Windproof Injection Base Water Weight Bags Sandbag Brand Name bagease Place of Origin China Product Name Water... |
YANTAI BAGEASE PRODUCTS SUPPLIES MANUFACTURING CO.,LTD.
|
|
|
Brand Name:VPOP Model Number:cardboard display Place of Origin:Guangdong, China (Mainland) ...,Clothing, retail and wholesale, to custom Food, cardboard boxes and Toy Display Stands. Brand Name Vpop Display Place of Origin Guangdong, China Material ... |
Vpop Display Products Ltd
Guangdong |
|
|
Model Number:1107.110 Place of Origin:made in China Description Wholesale Best Price 150cm Modern Commercial Shade Scallop Edgen Grass Patio Umbrella Factory direct supply 1: Product Size:: Can be customized 36”,40”,46,48”, 52”, 56”, 60” These are common specifications, if there is no ... |
Ningbo Walkingworld Leisure Products Co.,Ltd
Zhejiang |
|
|
Brand Name:GRH Model Number:GRH-E001,GRH-RFC1004,GRH-RFC1005,GRH-RFC1011 Place of Origin:CHINA ...,China Modes of packing Packed in one carton Size:cm 36*68 Company Introduction: We support online retail and offline wholesale orders. If you order more than 10 pieces, please |
WENZHOU GRH MANUFACTURE CO.,LTD
Zhejiang |
|
|
Brand Name:FUSMIL Place of Origin:Guangdong, China Model: WT56 Product Size: 80*49*192 MM Battery: 103450/2000mAh Package Size: 128*51*131 MM Input/(Charge/ Use Time): 5V 1A Product Weight (N/G): 180g/234g Power: USB (Type C) Carton Dimension : 52.7*53*27.8 CM QTY/Carton: 80 pcs Carton Weight (N/G): 18.8KG... |
Shenzhen Xin Huachang Technology Co., Ltd.
Guangdong |